Forumsee logo
Forumsee » Marketplace » Motorbikes » Read message
RSS: Subscribe to RSS

Yamaha - Running odd need quick help

Yamaha YFM660R Raptor (2001-2005) - Yamaha ATV Forum - www.bluetraxx.com
So my 03 raptor 660 really hard cold start but when I get it going won't idle even with choke. Once it's warmed up it will idle good no problem. But what the problem is, is this. In like 2nd gear if I'm putting along and floor it, most of the time it will cut out for like .5 a second to a second then take off like it should. Like a hesitation. Sometimes if I'm cruising in third or fourth gear after a little bit it will like pop a little bit and throttle down. It will accelerate again if I give it more gas. Is that all carb related? I've cleaned them twice but didn't happen to check the jet sizes. Might be selling it tomorrow want it in tip top shape.

Sent from my iPhone using Tapatalk
Date: Feb 8, 2017    Labels: Yamaha


Last videos:

Kuryakyn Adjustable Passenger hi-way Pegs 7926
Kuryakyn Adjustable Passenger hi-way Pegs 7926
Custom Old School Fat Bob
Custom Old School Fat Bob
Harley-Davidson Breakout Front and Rear Axle Cover Kits
Harley-Davidson Breakout Front and Rear Axle Cover Kits
Harley-Davidson Breakout Front and Rear Axle Cover Kits
Harley-Davidson Breakout Front and Rear Axle Cover Kits
2011 Harley Sportster 1200cc 3.7k Miles Youtube Vid Brand New upgrades
2011 Harley Sportster 1200cc 3.7k Miles Youtube Vid Brand New upgrades
Amerideck hydraulic loading system
Amerideck hydraulic loading system
Amerideck hydraulic loading system
Amerideck hydraulic loading system
Redverz Expedition II Tent
Redverz Expedition II Tent

Tags

Cars ·
Travel ·
Pets ·
production-frontend